Bumblebee

From Hybridgraphics

(Difference between revisions)
Jump to: navigation, search
m (Reverted edits by 131.228.39.129 (talk) to last revision by 173.252.192.210)
(Restore page)
Line 2: Line 2:
[http://www.martin-juhl.dk/ Martin Juhl] started with the project and published under GPL v3 and now continues with [Ironhide] (deprecated). To improve co-operation, developers decided to fork the project into a team: [http://Bumblebee-Project/ Bumblebee-Project].
[http://www.martin-juhl.dk/ Martin Juhl] started with the project and published under GPL v3 and now continues with [Ironhide] (deprecated). To improve co-operation, developers decided to fork the project into a team: [http://Bumblebee-Project/ Bumblebee-Project].
-
This is very inseretting, You're a very skilled blogger. I've joined your feed and look forward to seeking more of your magnificent post. Also, I've shared your website in my social networks!
+
=== Installation ===
 +
Bumblebee 2.4 and before was written in Bash and has now been superseded by Bumblebee 3.0, which is written in C.
 +
Many distributions are supported, including Arch Linux, Debian, Mandriva and Ubuntu. For the latest installation
 +
instructions, see http://wiki.bumblebee-project.org/Install-and-usage.
 +
 
 +
Ubuntu users (especially when upgrading) see [http://askubuntu.com/q/36930/6969 How well do laptops with Nvidia Optimus work?]
=== Testing ===
=== Testing ===
Line 14: Line 19:
The FPS value will always be close to 60.  Instead you should do:  
The FPS value will always be close to 60.  Instead you should do:  
<pre>vblank_mode=0 glxgears</pre>
<pre>vblank_mode=0 glxgears</pre>
 +
===Configure it===
===Configure it===
On versions prior to 2.3, you had to run <tt>bumblebee-configuration</tt> to configure Bumblebee. Newer versions automatically detect the right version for you.
On versions prior to 2.3, you had to run <tt>bumblebee-configuration</tt> to configure Bumblebee. Newer versions automatically detect the right version for you.
Line 24: Line 30:
Version 3.0 and later can be uninstalled from the source directory by running `make uninstall`.
Version 3.0 and later can be uninstalled from the source directory by running `make uninstall`.
-
First, tahkns for all the amazing work and good support,I'd like to suggest enabling some means of us knowing about known bugs, so we don't notify you 1000 times about the same issue  For my projects I use bugzilla, but there are other solutions as well. Just anything so we are not blind and can limit flood to you guys.
+
===Reporting bugs===
 +
Run '''bumblebee-bugreport''' and follow the instructions, bugs or feature requests can be reported at http://Bumblebee-Project.org/issues.
 +
 
 +
==External Links==
 +
* [https://lists.launchpad.net/hybrid-graphics-linux/msg01607.html 10 questions and answers on Bumblebee]
 +
* [https://github.com/Bumblebee-Project/Bumblebee/wiki Bumblebee Project's Wiki]
 +
* [https://Bumblebee-Project.org/ Bumblebee Project homepage]
 +
* [https://twitter.com/Team_Bumblebee Bumblebee updates on Twitter]

Revision as of 14:19, 23 February 2012

Bumblebee allows you to run specific programs on the discrete graphic card, inside of an X session using the integrated graphic card. Martin Juhl started with the project and published under GPL v3 and now continues with [Ironhide] (deprecated). To improve co-operation, developers decided to fork the project into a team: Bumblebee-Project.

Contents

Installation

Bumblebee 2.4 and before was written in Bash and has now been superseded by Bumblebee 3.0, which is written in C. Many distributions are supported, including Arch Linux, Debian, Mandriva and Ubuntu. For the latest installation instructions, see http://wiki.bumblebee-project.org/Install-and-usage.

Ubuntu users (especially when upgrading) see How well do laptops with Nvidia Optimus work?

Testing

You can compare display performances with and without bumblebee :

glxgears
optirun glxgears

Note: when running just glxgears, if you see this message:

Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.

The FPS value will always be close to 60. Instead you should do:

vblank_mode=0 glxgears

Configure it

On versions prior to 2.3, you had to run bumblebee-configuration to configure Bumblebee. Newer versions automatically detect the right version for you.

Uninstalling

If you've installed Bumblebee through your package manager, remove it using your package manager.

Source

If you're really using an old version (from MrMEEE, versions prior to 2.3), you are screwed. If you have installed Bumblebee 2.4 from git, run `bumblebee-uninstall`. Version 3.0 and later can be uninstalled from the source directory by running `make uninstall`.

Reporting bugs

Run bumblebee-bugreport and follow the instructions, bugs or feature requests can be reported at http://Bumblebee-Project.org/issues.

External Links

Personal tools