Bumblebee

From Hybridgraphics

(Difference between revisions)
Jump to: navigation, search
(Update for new version)
(Installation)
Line 5: Line 5:
Bumblebee 2.4 and before was written in Bash and has now been superseded by Bumblebee 3.0, which is written in C.
Bumblebee 2.4 and before was written in Bash and has now been superseded by Bumblebee 3.0, which is written in C.
Many distributions are supported, including Arch Linux, Debian, Mandriva and Ubuntu. For the latest installation
Many distributions are supported, including Arch Linux, Debian, Mandriva and Ubuntu. For the latest installation
-
instructions, see https://github.com/Bumblebee-Project/Bumblebee/wiki/Install-and-usage.
+
instructions, see http://bumblebee-project.org/wiki/Install-and-usage.
-
 
+
=== Testing ===
=== Testing ===

Revision as of 02:13, 20 January 2012

Bumblebee allows you to run specific programs on the discrete graphic card, inside of an X session using the integrated graphic card. Martin Juhl started with the project and published under GPL v3 and now continues with [Ironhide] (deprecated). To improve co-operation, developers decided to fork the project into a team: Bumblebee-Project.

Contents

Installation

Bumblebee 2.4 and before was written in Bash and has now been superseded by Bumblebee 3.0, which is written in C. Many distributions are supported, including Arch Linux, Debian, Mandriva and Ubuntu. For the latest installation instructions, see http://bumblebee-project.org/wiki/Install-and-usage.

Testing

You can compare display performances with and without bumblebee :

glxgears
optirun glxgears

Note: when running just glxgears, if you see this message:

Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.

The FPS value will always be close to 60. Instead you should do:

vblank_mode=0 glxgears

Configure it

On versions prior to 2.3, you had to run bumblebee-configuration to configure Bumblebee. Newer versions automatically detect the right version for you.

Uninstalling

If you've installed Bumblebee through your package manager, remove it using your package manager.

= Source

If you're really using an old version (from MrMEEE, versions prior to 2.3), you are screwed. If you have installed Bumblebee 2.4 from git, run `bumblebee-uninstall`. Version 3.0 and later can be uninstalled from the source directory by running `make uninstall`.

Reporting bugs

Run bumblebee-bugreport and follow the instructions, bugs or feature requests can be reported at http://Bumblebee-Project.org/issues.

External Links

Personal tools